Jump to content


Photo

Overlay Mapping Issues


  • Please log in to reply
3 replies to this topic

#1 James Griffin

James Griffin

    Newbie

  • Ace Member
  • 9 posts
  • RM Skill - Jack of All Trades

Posted 15 March 2017 - 01:50 PM

First, I know that Kaus was banned

Second, Orange does the same thing

Third, Sleipnir is preferred as it worked well for me in VX but I can't even get it working even though there is an MV port

 

I'm really just looking an easy way to get this working somehow without having to deal with doing the entire map in Tiled and Krita because that is a pain because of automapping.

 

That said, I'm trying to play around with overlay mapping but have run in to an issue where the ground layer is over the stuff I added in MV like in the picture when I playtest. Overlay mapping is really something that RPG Maker should be able to do natively by now but lets not get in to that.

 

So if there is an alternative I'm missing or a fix I am unaware of I'd appreciate the assistance. Also sorry if this is in the wrong spot.

Attached Files



#2 Takeo212

Takeo212

    Procrastination Expert

  • + Sponsor
  • 1436 posts
  • LocationScotland
  • RM Skill - Game Developer

Posted 16 March 2017 - 05:45 AM

It mostly seems like a priority issue. What plugin exactly are you using? (provide a link if possible please~)

 

Your image is set as an overlay instead of a parallax which is why it covers the buildings. You'd need one that allows a "below character" layer.

One I use is the Bind Pictures To Map plugin. It allows you to have a below and above option of the pictures.

 

Providing your current plugin would allow us to check if a "below character" option is available and how to do so.



#3 James Griffin

James Griffin

    Newbie

  • Ace Member
  • 9 posts
  • RM Skill - Jack of All Trades

Posted 16 March 2017 - 09:31 AM

I'm using the Kaus Ultimate Overlay plugin, whatever the last version is, but I get the same results from Orange overlay as well. A bit more history then. It worked up until an update some time ago. Before the update it would have shown the house, after the update it stopped showing whatever I put in with the editor. I forget which update, but they changed the version or Java or something and I thought it was a compatibility issue. It was a major update though. If this is an issue specific to me I then I'll try a few more things like a reinstall of MV or something. Maybe redownload the plugins or something, thanks.



#4 James Griffin

James Griffin

    Newbie

  • Ace Member
  • 9 posts
  • RM Skill - Jack of All Trades

Posted 18 March 2017 - 08:21 PM

Ok, so I've tried everything easy I can think of to no avail in this order 

 

>Redownloading the latest Orange Overlay and Kaus' Ultimate Overlay (currently using Orange)

>Reinstalling RMMV

>Migrating my data to a new project

>Tried another map that was working, it is now broken

>Reinstalled again making sure to clean out the folder in Steamapps\Common as there were some files left there

>Created a completely new and clean project and did nothing other than add a fresh version of Orange Overlay, resized the starting map to 40x40, changed the tileset to exterior, added the image as ground using the appropriate note tag (<ground>), and added some tiles from a random building tile

 

All same results

 

It was working normally at one point 

 

it DID reopen my last project I had open after I reinstalled the second time so I think I need to figure out where RM hides all of its extra files. If anyone knows a direct way to fix this then help would be appreciated. Otherwise if anyone knows where the Steam version of MV keeps all of its hidden files or even the app id that would be immeasurably helpful because something stuck in that is likely the cause. Otherwise I really can't do anything.

 

You did ask for a link to the plugin, this is to Kaus' Ultimate Overlay, the two are functionally identical but this link explains where each layer goes. These are to my knowledge very popular plugins, and RM should really do this natively anyways because people have been making scripts/plugins for this for at least XP, VX, and MV. Anyways here is the link https://forums.rpgma...t-plugin.48593/


Edited by James Griffin, 18 March 2017 - 08:33 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users