Jump to content

Tidloc's Header

Recommended Posts

Tidloc's Header v.2.14.1
by Tidloc

I've decided to use this header instead of implementing everything inside my scripts as I first encountered the error of the stack going to deep by aliasing...
All adjustments that effect more of my scripts are listed in this script and most of them need this header to function properly.


  • It's simply the header of my other scripts ;-)
  • you may alter the count of accessiores your actors can equip.
  • you can add other item-categories
  • all items (consumables, weapons armors and skills) can have scriptcalls in their notetags as on-use-effect
  • You can set the first constant DEBUG to true to being transfered directly to the startin position without the title scene
  • for all my script: no known compatibility issues, if you encounter any, please post them, most are bypassed by listing my scripts beneath the others and disable the unwanted features by the switches as stated. Nearly all is aliased or at least disable-able :D
    of course this is not valid for scripts that may have the same alteration, like another single-item-script...
  • all of my scripts have a help window for special handling in each scene they effect. this help window is called by predefined button in the constant Keys["Help"].
  • During fights, it's possible to land a LimitBreak, like a critical of a critical
  • Critical chance for skills is directly adjustable and critical multiplier for each actor/enemy is adjustable.

no need?

How to Use
paste it of course above main, below all standart-scripts, but also above all of my scripts!
Detailed description on how to use this script in the first commented lines of the script
For altering the count of Accessoires, change the constant Accessoire_Count in the module Tidloc. Standard value is 1
For adding additional Item-Categories, change Item_Categories to = true. Below you can change the Names of your Categories., you are also allowed to have more then this three categories used by me, simple seperate them with comas. To assign an item to a specific category, write into its description either of the commands:



where *ID* is an integer equal one or greater.

Demo for the available tags, classification of items and my item scripts.

Download this file: https://www.dropbox.com/s/4yujoic1gcm69d7/tidloc_header.rb?dl=0
If you want my independent ingame clock:


Download this addition.
for this, you need an image in the pictures folder, like this:
with an image for each timestep, placed next to each other.


Q: I found a bug or have a suggestion, how ca I contact you?

A: please look into my signature, there you'll always find the most recent contact information!

Q: How do I add quests to the questlog?
A: please see the document also listed for downloading.

Q: Is there a way to get rid of "Manuals, Resources, Runes" from the menu because I don't use them at all.
A: set the key :item_categories to false.

Q: How do I set a certain category to an item as they are used in this script?
A: See the spoiler in "How to use" above

Credits and Thanks
- Tidloc

Links to my finished scripts here
    Alchemy Script
    Item Dismantling
    Dynamic Shop System
    Popup Message Windows
    Compass script
    Auction System
    Automatic Minimap script

    Custom Equipment
      Diablo Equipment (Equipment Script enhancement)
      Socketed Equipment (Equipment Script enhancement)
      Equipment Durability (Equipment Script enhancement)
      Exp Equipment (Equipment Script enhancement)
    Lockpick Minigame
Download only
    for most of my scripts handy:
      HTML Interpreter
    for Data- and COMMAND-purpose:
      Item Data
      Weapon data
      Armor data
      Actor data
      Enemy data
      Skill data
      State data

I'm always open to suggestions or ideas, so feel free to contact me =))
Also if you encounter an incompatibility with any other script, contact me! By the size and impact this header has, this can occur, but I'll try my best to make it compatible with the work of others and I should be able to make most of them compatible!  (as long as I didn't mention in the according script that they are indeed fundamentally incompatible.)



02/21/2012: 1.1: Questlog added
02/22/2012: 1.2: Alchemy Script added and fixed one little bug thx to Non Ya xD
02/28/2012: 1.3: Dismantling and Dynamic Shop added
03/03/2012: 1.3.1: added the possibility to change scripts into spanish. Vocabulary already entered in Questlog
04/07/2012: 1.4: some minor bugs fixed, reprogrammed some parts into better symantic and enabled calling some scripts over the main menu or by Key.
04/18/2012: 1.4.1: some bugs fixed, now everything should work fine! =))
05/06/2012: 1.5: added the popup message script and a major update to the header to version 1.5 (some bugs and some alteration for existing and future scripts made.
05/25/2012: 1.6: added the compass script
05/27/2012: 1.7: added the auction system and updated most of my scripts
06/02/2012: 2.0: new release out! completely rewrote some parts of all scripts, especially the vocabulary party to supply multi-language games. If you update this header, all of my other scripts(if older then this point of time) also need to be updated. Also each script has now five additional constants in the beginning.
02/05/2014: 2.1: added the language script, resolved some minor bugs and smoothed some parts.
02/13/2014: 2.2: added Custom Equipment and Diablo Equipment
02/16/2014: 2.3: added socketed equipment and a big update to support commands throughout my scripts (welcoming any special suggestions on this part! ^^
02/17/2014: 2.4: added the possibility to have scriptcalls directly in the notetags of items/Equipments/skill for an effect if you use them (Tagged Equipment now is also use-able in fights and in the item menu)
02/20/2014: 2.5: added HP cost and Max-HP-% cost adjustable for skills and improved display of item categories
02/22/2014: 2.5.1: added an independent ingame clock as addition and updated some parts, so my dynamic shop becomes compatible with my custom equips
02/26/2014: 2.5.2: fixed a bug the yanfly battle engine induced in my scripts
03/02/2014: 2.5.3: HTML now supports data in Rect as positioning and textwrap implemented.
08/30/2014, 2.6: Added code for my custom items to be able to level and for my rune script
02/08/2015, 2.6.1: Resolved a bug with equipment script
02/24/2015, 2.6.2: Resolved a bug with message windows
07/10/2015, 2.7: invented the constant DEBUG, partly rewrote some of my more complex scripts and fully inserted the scripts CustomSkills and Runes to the header. Also invented additional parameters Dex and Vit. If you don't want to use them, you don't need to, they are just an addition.
07/13/2915, 2.8: invented a help window for all my alterations to be opened when in the certain scenes, they effect. Also the Help Array has been introduced.
07/18/2015, 2.9: implemented additional contants for Vit and Int boost of HP/MP and to display an Icon or an image instead of the moneyword. Moved some scripthandling fro game_temp to game_system and overworked most of my older scripts.
07/26/2015, 2.9.1: Moved the Params to the module Vocab and rewort the param subroutine from the Vocab module of standard RM VXAce script.
08/02/2015, 2.10: included a descent version check and altered some parts for skill scripts
08/04/2015, 2.10.1: implemented limit breaks
08/06/2015, 2.10.2: implemented the constant Param_Names for my scripts to get language-independent tags for the params
08/06/2015, 2.10.3: implemented multi-language support, also with enemy-/item/actordata
08/12/2015, 2.11: implemented modification to critical- and limitbreak-damage per actor/enemy via notetags to fixed values of referring to game variables. Added modifiable critical chance for skills.
08/14/2015, 2.11.1: included need_healing in the class game_party and implemented a routine to transpose matices.
08/17/2015, 2.11.2: included the Equipment refining and item durability scripts.
08/29/2015. 2.11.3: added minigame handling
09/24/2015, 2.11.4: bugfix with LB notetags, added an option to show all items of all categories as long as the item window isn't active
11/01/2015, 2.12: added minigame handling
11/29/2015, 2.12.1: corrected display of item categories, causing problems with third-party-scripts
12/22/2015, 2.12.2: added a new command "Use" for all items/skills
01/22/2016: updated Demo-link
02/15/2016: 2.12.3: fixed a bug, related with some battle systems
02/20/2016: 2.13.0: added voucher system
02/27/2016: 2.13.1: changed the handling of item categories in the category window, enhanced the handling of the "Use"-command on items
03/29/2016: 2.13.2: fixed memory leaks in the Item Scene
06/01/2016: 2.13.3: added support for the Item Shop Ban enhancement for my custom equipment and the exe commands
06/10/2016: 2.13.4: added support for the Minimap script
06/10/2016: 2.13.5: several Bugfixes
07/09/2016: 2.13.6: updated published scripts, bugfixes for minimap support
07/13/2016: 2.13.7: fixed a minor bug in calculating critical damage and probability, also fixed a major bug in the HTML script
07/15/2016: 2.13.8: fixed a bug that can appear when consuming items
12/26/2016: 2.13.9: added handling for my custom skills that need to be activated through exp
05/27/2017: 2.13.10: adjusted to an improvement in the MessageWindows script
06/08/2017: 2.13.11: rewrote additional damage sections for my custom equipment scripts
06/23/2017: 2.14: added a global data folder for data files of my scripts in the configuration of the header, only used in an unpublished script atm
06/24/2017: 2.14.1: fixed a bug with LB calculation and added the notetags <lb-add-dam *x*> and <crit-add: *x*>

09/24/2017: updated download links

04/29/2018updated my contact information


Edited by Tidloc

Share this post

Link to post
Share on other sites

I may be an idiot but when i start the game i get this error:


undefined method 'set_battle_system' for #<Game_System:0x7734f18>


What am I doing wrong?

Share this post

Link to post
Share on other sites

Aweome script, yet I have a small problem with it. I can load from the menu but not from the title screen.


(Genauer gesagt: Wenn ich Continue im Titelmenü auswähle, werden mir die Savestates angezeigt, aber wen ich mit Enter bestätigen möchte passiert nichts. Das Laden im Menü funktioniert jedoch ohne Probleme. Habe das Script in einem neuen Project probiert und hatte selbiges Problem.)

Share this post

Link to post
Share on other sites

@Draqun: I also figured this issue and was solved the day you posted it... xD

@Facinus: Thanks for the bugreport, now it's solved and working! ^__^

Share this post

Link to post
Share on other sites

Hey there,


Is there a way to get rid of "Manuals, Resources, Runes" from the menu because I don't use them at all.




Figured it out, nevermind :)

Edited by Abysinian

Share this post

Link to post
Share on other sites



I wanted to use this script in my project with http://www.rpgmakervxace.net/topic/1393-tidlocs-alchemy-script/


I installed the header first, and under the header the alchemy script. But every time, i start the game, i get the message:



Script 'tidloc_header' line 595: No MethodError occured.

undefined method 'load_alch_data' for Tidloc_Alch:Class


A compatibility issue is out of the question, because this problem occures even with an new, empty project.


Is there any way to fix ist?

Share this post

Link to post
Share on other sites

Well, for some reason the laptop I am using can't open .rb files. I don't suppose you could up this as .txt by any chance?


EDIT: Actually it's okay. I got the script from the Demo for your Questlog script. Cheers! x :)

Edited by Paddy

Share this post

Link to post
Share on other sites

well, in the demo it's hardly the actual version of the scripts...

how to open .rb-files, three ways(if one isn't possible on your PC go to the next)

1. have notepad++ or any other scripting/compiling/intepreting editor

2. right-click file, select edit

3. right-click file, select open with, choose editor or notepad

Share this post

Link to post
Share on other sites

Really Nobody, who has a clue to my problem?


I download the demo from http://www.rpgmakerv...alchemy-script/ to test it again and again. But the game crashes instantly, if i try to start the demo as a game, or a test game... obviously i'm the only one, with this problem, but it seems impossible to me, make the script work.


Test the Demo? Crash.

Test with my Game-Project? Crash

Test with an Empty Project? Crash

Test as Administrator? Crash


... Where is my Mistake? Why forces the header my RPG-Maker to crash, every Time i install the Alchemy-Script? The Failur Message is either


Script 'tidloc_header' line 595: No MethodError occured.

undefined method 'load_alch_data' for Tidloc_Alch:Class


in my game. Or


Script 'tidloc's_Alchemy' line 677: SyntaxError occured.

unexpected keyword_end, expecting $end


in the demo.

Edited by Andynator

Share this post

Link to post
Share on other sites


err... first you could take a look into your PMs... (wrote you like over a week ago!)

or here in short:

did you download the most recent versions of my scripts?

I'm using these scripts without any problems...

Regarding the demo: updated the link, but somehow it only updated the visual part, not the link itself too... corrected that please try again (demo-link was way outdated)

but if you intend to use my scripts, I recommend to download the most actual versions (the .rb-files in the corresponding threads)

Share this post

Link to post
Share on other sites

Hello there. I am attempting to use your header in conjunction with your alchemy script. I have not modded the scripts in any way but simply placed them as is within the script editor. When I run a playtest of my game I keep getting this error: "unable to find file: data idloc.ini"


I am a complete newbie to all of this so I have no idea what that means. My apologies.

Edited by zogoto3000

Share this post

Link to post
Share on other sites

I'm quite sure it said tidloc.ini, the point is you need a file called tidloc.ini in your data-folder, as described in the thread of my alchemy script. if you follow the steps there, you will get it running in no time, but you have to write all the recipes by yourself in that file ;)

Share this post

Link to post
Share on other sites

Hmm, regarding the "Manuals, Resources, Runes" thing...what are they for? Because I want to use them, but I don't know how. Unless they're useless and there for nothing.

Share this post

Link to post
Share on other sites

these additional item classes can be used be setting the notetag


for the items. (not working with weapons or armors)


where 1 is the the first additional category, 2 is the second,....

if you want to keep the item in the normal item-view, then leave this notetag out :)


Edit: also updated the How To above to line that out! ;)

Edited by Tidloc

Share this post

Link to post
Share on other sites

Hi, just made an account to ask this and I'm a complete newbie so forgive me if it's really obvious XD

I just installed the Header and haven't changed it at all. It works but as soon as I try to access the Weapons menu in my game it crashes and gives this error:

Script 'Tidloc Header' line 1030: NameError occured.

uninitialized constant Window_ItemList_2::Game_CustomEquip

I have no other scripts installed but your message window one and your quest system. I'm not sure if it might be affecting things but I'd created a new weapon type before adding this script called 'Hair Ornaments' and set one character to start off with them equipped. (Don't ask. The guy fights by flicking his hair at people XD) But I also made new classes and new armor types and no errors there...

EDIT: Actually upon double-checking it gives the error for armor as well. I think it must be my custom types that's the problem, I just can't figure out how I'm meant to make the script recognise them. God, I'm useless! XD

EDIT: Okay now I don't even know what was wrong but I seemed to fix it by changing:

when :weapon

item.is_a?(RPG::Weapon) || (item.is_a?(Game_CustomObject) && item.object.is_a?(RPG::Weapon))


when :weapon

item.is_a?(RPG::Weapon) || (item.is_a?(RPG::Weapon) && item.object.is_a?(RPG::Weapon))

Looks very repetitive now but works just like it did before inserting the header. I am officially baffled.


P.S: Thank you so much for the Questlog script! Just wondering- is there any way to change the description scroll keys? (pageUp and pageDown by default, I wanted to perhaps change it to the up and down on the num pad) I found it a little unintuitive and would never have guessed what to press if it weren't for the demo.

I'm attempting to repurpose this into an info encyclopedia so there's gonna be a lot of scrolling. By the way, the external loading add-on is really awesome! Much easier for a confused noob :3

Edited by Bunni89

Share this post

Link to post
Share on other sites

thanks for your interest in my scripts ^^


yes, this lines are for a script I work for and I know that issue... this (let's call it a) beta-version of my header shouldn't be up, at some time I copied it and the old one is now unfortunately gone.


Yes, there is a way, but only if you got some kind of keyboard-script too, because by default these keys are not sampled by RGSS. (I made it this way, so it can be used by nearly everyone xD )

And that's what the demo is for: to show the functionality ;P

fyi, these keys are defined in lines 795 and 797 ;)

Share this post

Link to post
Share on other sites

I really want to use your QuestLog, but all the "additions" you put in the Header make it incompatible with the highly customized Yanfly Menu I'm using. Is it possible to include the Header parts for the Questlog to work, but get rid of all of the extra accessory and menu altering (save, load) parts of the Header? I'm attempting it, but I was hoping you could point me in the right directions (or let me know if it's possible). Thanks.

Share this post

Link to post
Share on other sites

ok, new version is up, now you got between the lines 55-57 the hints how to completely disable the features of my header. ^_^

Share this post

Link to post
Share on other sites

Sorry to sound like an idiot here, but im kinda lost.

After an hour of trail and error and searching, i have no idea what on earth the script means by the category id, or if im doing that wrong, how on earth each item goes into each category, since the script gives no real instruction of that

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Top ArrowTop Arrow Highlighted