Jump to content
Sign in to follow this  
Glyxis

Transferring with variables

Recommended Posts

Hello. I have issue about transferring with variables. The situation is this: I want to use item, which change the the map. In my case, i use item in lavacave and that hardens the lava so i can walk on it. So, i have exactly the same map, but only the lava tiles is changed. (When i use it, it shows animations and flashes the screen and then the map should change)

The problem is that, i can use this item anywhere, so the player must transfer on same spot where he stands on earlier map. I have almost to get it work. (I know it can be done by "Map ID" and "Player Map X & Y" but still i need help.

 

EDIT: PROBLEM SOLVED!

Edited by Glyxis

Share this post


Link to post
Share on other sites

I think the way to do it is to set a variable for player map x and player map x and then transfer them to the new map with the same variables for position. I'm pretty sure theres a change tile event as well, so you could just make a lava event and have it change depending on whether the item switch is on or not. That should work...

Share this post


Link to post
Share on other sites

@ GryphonBlade77: Yes, that what i was doing, but there is something wrong.. And no, there is only "Change Tileset" command, so you can't change specific tiles.

 

@ TheHarmp: I have set it like that. It didn't change the map. Something is still missing. I tried to add "Get Location Info" command but it transfer in my first map? I can't understand why..

Share this post


Link to post
Share on other sites

Make sure you don't set map id to map id, because it will set it to the map you are on.
instead set the variable map id to the map id of the map you want to go to. (Control Variables: [0006:map id] = X) (where X is your map id)

That should work.

Share this post


Link to post
Share on other sites

Mmm.. I still don't get it where and how i put the information that transfer me into map 6? (In my case, map 6 is the map where i want to transfer) Here's the pic.

jmq6.png

 

EDIT: Oh, i got it! Of course i set constant to 6! Damn i'm stupid :wacko: So, PROBLEM SOLVED! Thank you TheHarmp for help :)

Edited by Glyxis

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×