Jump to content
Sign in to follow this  
Biggest_Queen

Background Music Doesn't Loop

Recommended Posts

Okay, I came across yet another problem while making my game and this one is just puzzling to me. Basically, some of the BGM that I have playing in my game does not loop. It just fades out and then it's just dead silence for minutes on end. I have waited a few minutes, not that it just takes a while, but to no avail.

 

Does anyone know why the BGM isn't looping and how I could fix it? I'm not really trying to get it to loop at certain points, I just want it to keep restarting from the beginning, as usual. If it helps, I have a custom song and that song is an .ogv file. Another weird thing is that some of the other custom songs in the game DO loop correctly, even though the songs are the same file type. Is there something I'm missing? Is there a script I need to fix this issue? Any help is appreciated.  :(

 

EDIT: What I did notice is depending on the converter I use, the file output will be either .ogg or .ogv. Is it that the ogv isn't registered to really loop whereas the .ogg is?? That's what my theory is at the moment and I'll probably try a different converter to get the .ogg file but if it doesn't work then I have no clue.

 

EDIT: Okay, I converted the .ogv file to an .ogg file and now it's looping correctly. Welp, I just feel reeaallly stupid now xD At least I figured it out. This thread can be closed now, if it can even count as a thread.

Edited by Biggest_Queen

Share this post


Link to post
Share on other sites

Because .ogv is a video format. I'm wondering how did that work in the first place. :D

As you have noticed ~ .ogg is the correct format and it is the preferred format for music in Ace games.

 

Glad you managed to find the solution. ^^

 

9RWO0dm.png This thread is closed, due to being solved. If for some reason anybody would like to re-open this thread, just send me a PM or report the thread. (=

Share this post


Link to post
Share on other sites

Okay, so a similar problem emerged now in which the BGM is acting funky. Similar to what happened before, the BGM didn't loop and faded out into dead silence. Well, after I had converted all the music to oggs, everything appeared to be working fine...until it happened again. Basically, in some areas in my game, it is one "area" per-say but is subdivided into several different maps. One of these is the king's castle, which has like over 5 maps including the rooms. If the player transfers from one of the maps to another as the music starts to end, then it won't start back up again. So this caused me to think that the way I was having the BGM play throughout the maps isn't correct. The way I did it was that the FIRST map of the area that the player steps into auto-changes the BGM and then all the other maps in that area don't have it automatically changing; then I tried making EVERY map auto-change the BGM but that didn't really help either.

 

Is there a specific way to do assign a BGM across multiple maps? Is it possible that anything else would cause this sort of issue?

Any help is appreciated.  :(

Share this post


Link to post
Share on other sites

It definitely is possible and.... you don't even have to do anything ~ just don't change the BGM between maps and it will be playing even between different scenes. The BGM will keep playing forever as long as you'll not stop/replace (with other BGM) it or shutdown the game.

 

Does the BGM loop properly in Sound Test in the Editor? If it doesn't work here as well, then I'm suspecting, that the file itself has incorrect format or isn't configured properly to loop and/or the track has a very long silence part at the end, that just needs to be cut off.

 

Is the music file correct? Or if you want, you can send me the music file and I'll check it ~ at least that way I could exclude the possibilities related to the file. It definitely would be better if the issue was related to the file, because other than that, I'm not sure how exactly that issue looks (or sounds, I should say) like, so it would be much harder to locate the problem.

Share this post


Link to post
Share on other sites

I'm happy to say, that the file is corrupted*, so perhaps that's why it doesn't want to work.

* corrupted - My music player and sound editing software refuse to open the file. Music player says, that the format is incorrect or the file is damaged (that player supports ogg's by the way), while the sound editing software just freezes and crashes when trying to open the file.

Why happy? Because at least (most likely) we found the source of the issue, so we can take next steps.

I suspect, that something went wrong during converting. This file is just broken. If you'll send me the original format (mp3 or whatever) then I'll convert it by myself and then you'll check if it will work for you.

 

 

And no, transferring to other maps has nothing to do with loops (to BGM's yes [like changing BGM etc.], but not to looping), unless the file is broken in a very specific way, which results in such a weird behavior. Either way, as long as the BGM isn't changed after changing the map, then the current one should be playing perfectly normally.

Share this post


Link to post
Share on other sites

Here's the file: <LINK EXPIRED>

Check if it works for you, because it does work for me.

 

I'm using Audacity (It's a sound-editing software) to convert and/or edit sound files. Online converters usually are terrible.

Share this post


Link to post
Share on other sites

Okay so I replaced that old song with the Audacity file and made only the first map auto change the music and so far it seems to be working. I haven't really noticed any sudden stops in the music as I transfer between the maps. I'll come back if I do happen to stumble across another problem, but so far, I think I'm golden. Thank you for suggesting the Audacity program too, I'll convert the songs in the game into ogg vorbis using that program instead.  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×