Jump to content
Revival

VX Ace drawing random square in text

Recommended Posts

Squares.png

 

The picture is pretty self explanatory. But in the database the enemy's name is Just "Imperial c**k" nothing follows the k, however its always displaying those stupid squares that appear when there's missing characters.

 

I noticed on the character bios it does the same thing when I press enter to go to the next line.... I found using space bar then placing a dot offscreen fixed it for the bios, but that fix won't work for enemies, any ideas on what's causing this?

Share this post


Link to post
Share on other sites

I've had this same problem when inputting text via Tidloc's Questlog Script. I thought it was just me.

 

It's a very odd occurrence, and it looks stupid.

Share this post


Link to post
Share on other sites

I've had this same problem when inputting text via Tidloc's Questlog Script. I thought it was just me.

 

It's a very odd occurrence, and it looks stupid.

 

Well I don't have that script, but I do have a TONNE of Yanfly scripts, which I know were translated... has me worried I'll have to go through them ALL :/

Share this post


Link to post
Share on other sites

Don't worry about it, I'm pretty sure it's a problem with the editor itself. I wonder what exactly causes the issue.

Share this post


Link to post
Share on other sites

If you think it's a problem with the editor just remove all the scripts and see if it still happens.

 

If you're using the japanese editor then it is probably the editor.

Edited by Tsukihime
  • Like 1

Share this post


Link to post
Share on other sites

i exp. that when i inserted a text cache or cache optimization script.... try commenting out the scripts that affects the text.

Share this post


Link to post
Share on other sites

i exp. that when i inserted a text cache or cache optimization script.... try commenting out the scripts that affects the text.

 

Please explain how I would comment something out, and what effect would it have? because I did insert a script that changed the font size, due to the overly huge default, and I have no experience beyond plug and play scripts and very minor adjustments on vx.

 

The snippet I used is here: http://www.rpgmakervxace.net/topic/3926-how-do-i-change-the-default-font-size/

 

third comment, thanks in advance!

Share this post


Link to post
Share on other sites

Since this appears to be a script issue, I've moved this to Script Support.

Share this post


Link to post
Share on other sites

can you list all the scripts that you have so that we can breakdown the conflicts

Share this post


Link to post
Share on other sites

I actually have no reason to believe this is a script issue or compatibility issue, like another poster here said, he has the same issue... all my scripts are Yanfly scripts and are therefore meant to work together... the only exception is the one I've posted here...

 

Actually, I was wrong, I have 2-3 that aren't yanfly I did however get them from Yanfly's blog, so I assumed they were compatible... I'll upload my project now (safe for the bgm, so for testing purposes change the bgm to whatever you want) It's only 5 maps so the filesize shouldn't be huge I'll edit post when it's up

 

 

To whoever sifts through these scripts, you're a saint and I thank you in advance: http://www.mediafire.com/?1smbrxnqjcice8a

 

It is in .rar format, I completely forgot the maker had it's own built in compresser since my last game was too big to compress (VX) I never used it :3

Edited by Revival

Share this post


Link to post
Share on other sites

See I haven't tried because there's just so many scripts (40+) and originally I wasn't even sure it was script problem or not, to be honest I still don't know, but in order ot know I'd have to add and remove scripts, which is difficult because some scripts are completely reliant on others... one thing I noted though, this happens not only in battle, but also in character biographies, which would be to unrelated systems, which is why I can't tell . Now I'm certain it's a script issue though, because I just tried it in a game without ANY scripts at all and it didn't show the squares :/ but pinpointing the problem is the new difficulty

Share this post


Link to post
Share on other sites

Chances that it's a script issue if it doesn't occur in a default project is pretty high.

 

Game messages are all handled by the same thing, so it's likely the scripts that are affecting how text is displayed.

 

Of course, any script could be modifying how text is displayed if the author felt like it, so who knows....

Share this post


Link to post
Share on other sites

Chances that it's a script issue if it doesn't occur in a default project is pretty high.

 

Game messages are all handled by the same thing, so it's likely the scripts that are affecting how text is displayed.

 

Of course, any script could be modifying how text is displayed if the author felt like it, so who knows....

 

I'm investigating now, I guess :/ It'll take a long time, but when I find out which one it is, I'll update the op.

 

 

EDIT: Okay, so I'm 100% sure this script is the problem, I took it out and the square went away, the only problem is, I need that script, the default font is too big, what should I do?:

 

 

#==============================================================================

# Script that changes the default font settings.

#==============================================================================

 

Font.default_size = 25 # Default - 20

Font.default_name = ["VL-Gothic"] # Font names are used in order. If the first is not available, the second will be used, etc..

Font.default_bold = false # Default - FALSE

Font.default_italic = false # Default - FALSE

Font.default_shadow = false # Default - TRUE

Edited by Revival

Share this post


Link to post
Share on other sites

What character should appear behind the enemy's name (instead of the square)? Perhaps, "VL-Gothic" doesn't support that character and prints the square instead.

Share this post


Link to post
Share on other sites

Hmm... I think I have an idea, but I'm not 100% sure I'm right...

 

Could you take a look at this thread here and see if that helps you any? Again, I have a theory about this, but I'm not 100% sure.

Share this post


Link to post
Share on other sites

What character should appear behind the enemy's name (instead of the square)? Perhaps, "VL-Gothic" doesn't support that character and prints the square instead.

 

Edit: I did what IceDragon said and changed the font to Unicode

 

Then this:

Hmm... I think I have an idea, but I'm not 100% sure I'm right...

 

Could you take a look at this thread here and see if that helps you any? Again, I have a theory about this, but I'm not 100% sure.

 

All I had to do was refill in the LETTER_TABLE_FULL under Game_Troop with the right letters now it all works!

Edited by Revival
  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
Top ArrowTop Arrow Highlighted