Jump to content

Recommended Posts

I booted up RPG Maker VX Ace for the first time a few days ago and started working on an old project. I was messing with a new tileset I've installed and as I was getting the feel of how the tiles worked, I shut my laptop, reopened it and....crash. I had to force turn off my laptop. Now when I try opening the exe, RPGVXAce Project (.rvproj2), it said.

Spoiler

image.png.1bbab232d6b1f73b15b72b4e37dfc981.png

So I copied and replaced that dll file, and now it's saying.

Spoiler

image.png.1b6f76f4d5ebd11f6aeacbd268c5355d.png

So, what do I do now? Start from scratch, or is there a way to resolve this? And not sure if it'll help, but here's the error log.

Spoiler

Theo - Basic Modules v1.5d:617:in `initialize': No such file or directory - Graphics/Pictures/Night, Errno::ENOENT
    from Theo - Basic Modules v1.5d:617:in `initialize'
    from Cache:106:in `new'
    from Cache:106:in `normal_bitmap'
    from Cache:91:in `load_bitmap'
    from Cache:57:in `picture'
    from Venka's Bestiary v1.8:2095:in `rescue in enemy_image'
    from Venka's Bestiary v1.8:2089:in `enemy_image'
    from Venka's Bestiary v1.8:2053:in `update_enemy_image'
    from Bestiary Actor's Input Addon:337:in `update_enemy_image'
    from Venka's Bestiary v1.8:2040:in `update_enemy_info'
    from Bestiary Actor's Input Addon:329:in `update_enemy_info'
    from Venka's Bestiary v1.8:1935:in `command_bestiary'
    from Window_Selectable:212:in `call'
    from Window_Selectable:212:in `call_handler'
    from Window_Command:136:in `call_ok_handler'
    from Window_Selectable:322:in `process_ok'
    from Window_Selectable:297:in `process_handling'
    from Window_Selectable:276:in `update'
    from Venka's Bestiary v1.8:1055:in `update'
    from Scene_Base:95:in `block in update_all_windows'
    from Scene_Base:93:in `each'
    from Scene_Base:93:in `update_all_windows'
    from Scene_Base:49:in `update_basic'
    from Theo - Pause anywhere:99:in `update_basic'
    from Scene_Base:41:in `update'
    from Bestiary Actor's Input Addon:352:in `update'
    from Scene_Base:14:in `main'
    from Mithran - Graphics Obj Ref:246:in `main'
    from SceneManager:23:in `run'
    from Demo Util:995:in `run'
    from Main + Debug:10:in `block in <main>'

 

Share this post


Link to post
Share on other sites

I would start with a new project and test it. Then copy over a piece at a time from the data folder and graphics folder or others if you use dll's and such.

Actors, then classes, then armours, etc. when you get to the point where it stops, then you know which one is bad, if any.

Share this post


Link to post
Share on other sites
1 hour ago, Darkness Void said:

I shut my laptop, reopened it and...

#MistakesWereMade. Should never, ever do that with anything running, especially not foreground-running applications like RPG Maker. It's actually risky to allow screensaver applications to run whilst RPG Maker is also running (depending on what resources the .scr file accesses).

However...
Those DLL error messages tell me that Windows is not indexing the DLL properly (an unfortunately common occurrence especially from Windows 8 onward), and thus, if this is a Windows DLL Indexing Error, starting a new project is going to have similar issues, if it even works at all. The fix? Well, that depends on if the DLL Indexing Error is just with that DLL, or several, or most of them. If it's more than nine of them, or worse, most of them, it's a kernal issue. Such requires an OS reinstallation. Otherwise, it's a registry dive.

It's also possible that there's a weird filesystem error that resulted from you shutting your laptop. A hard reboot may be needed. Or, again, you can dive into the registry.
Hard Reboot: Shut down, and discharge the components (unplug from external power). After rebooting, some things may need to be set again, depending on numerous factors.

Share this post


Link to post
Share on other sites
12 hours ago, PhoenixSoul said:

#MistakesWereMade. Should never, ever do that with anything running, especially not foreground-running applications like RPG Maker. It's actually risky to allow screensaver applications to run whilst RPG Maker is also running

That happens mostly with Flash Macromedia unless I close its window first, but when you have 2 toddlers you tend to forget these things. At least I save constantly after few minutes.

Hm, well other editors can open up other projects with no issue so it's definitely just this one editor. I'll try what roninator2 suggested and if that doesn't work I'll try the hard reboot. The only thing I dread about beginning from scratch are the scripts..

Share this post


Link to post
Share on other sites
11 minutes ago, Darkness Void said:

The only thing I dread about beginning from scratch are the scripts...

There's a script that allows one to export all scripts to an external file (they're separate entries). I forget who wrote it, but it will allow one to preserve the script data in .rb format.
@Tsukihime also wrote a script for automatically backing up data.

Share this post


Link to post
Share on other sites
25 minutes ago, PhoenixSoul said:

There's a script that allows one to export all scripts to an external file (they're separate entries). I forget who wrote it, but it will allow one to preserve the script data in .rb format.
@Tsukihime also wrote a script for automatically backing up data.

I've created a new project folder and copied over everything but the two files named Game, and it seems like the problem is coming from the Data folder.  First it was Common Event Data, then System Data, and now Map Data..

 

So what do I do? Just use an old backup and redo everything from the ground up? Or is there another way to fix these files?

Share this post


Link to post
Share on other sites
14 minutes ago, Darkness Void said:

Just use an old backup and redo everything from the ground up?

Yes, unfortunately. VX Ace is not good at saving projects. It's very buggy.

Share this post


Link to post
Share on other sites
57 minutes ago, PhoenixSoul said:

Yes, unfortunately. VX Ace is not good at saving projects. It's very buggy.

I booted up a few of the data files in Notepad and Notepad++ and, one was blank, one was in something like Chinese text and another is clearly corrupted text.

Is any of that normal? To be honest starting from scratch wouldn't be too bad, I can reuse everything from graphics to sound, and it'll help me relearn the script for the combat.

But I'm just going through everything first before hitting the reset button.

Share this post


Link to post
Share on other sites

The blank file was in the process of 'delete and resave'. Yeah, it's VX Ace behavior.

Share this post


Link to post
Share on other sites

I was able to fix the editor. I went into the Data Folder and hit the restore button on the files it was having trouble with. So that's lucky. I still have to add a bit of my progress but at least I didn't lose everything.

  • Like 1

Share this post


Link to post
Share on other sites

This is a bit late but yes I've had this happen, backups are very important, I normal straight click the data folder & make it a rar

every time I'm done, that way the if the pc crashes & the data corrupts you have the last point you started with saved at least.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
Top ArrowTop Arrow Highlighted