Jump to content

Recommended Posts

Hi, Sorry I need some help again. I've been trying to get enemies to play an explosion animation right when they die. But it always fades instead. I put Enemy Die Animation tag in the enemy database. I'm not sure what I should do to get it to work.

Share this post


Link to post
Share on other sites

I would check to see if it doesn't work with any animation. Maybe the default database animations don't work with it because they're too big, try the ABS animations and see if those work. If it works in the demo, take the same setup from the demo (enemy note tags, animation used, etc) and recreate it in your project. If it still doesn't work, then we need to see everything involved, which can get tricky but is doable

Share this post


Link to post
Share on other sites

Well what I mean by that is the default animations in the database are all much larger (literally bigger) than what you would use because they're meant for a different battle scene. If you look Falcao added a bunch of new animations which are really just resized (they start with "--") and those definitely work. Maybe you're using a database default animation as opposed to a properly sized one and that's why it's not working?

Share this post


Link to post
Share on other sites

Here is the one that do work.

  "Enemy Sensor = 4
   Enemy Die Animation = 15
  "

 

Here is the one that don't work

  "Enemy Sensor = 4
   Enemy Die Animation = 113

  "

There's really no difference. I even used Est's Script Control to disable all scripts other the base pearl abs scripts, but I still get the same result.

Share this post


Link to post
Share on other sites

Sorry I'm an idiot. I don't know understand what you were asking for. But I hope this pic will do. The left is the clean version. The right is the game I'm making. I really appreciate the help by the way. (Sidenote, I editted my notetags hoping something would happen but nothing. I also copied all of the scripts I'm using to the clean version to replicate the problem but animations still played when enemies die. The only difference at that point is that I used the limit breaker for database on my game.)

 

 

 

RbcSYgf.png

 

 

Share this post


Link to post
Share on other sites

If you used woratana's Limit Breaker script, you need to remove that script after you have run it once.

If you did that, it shouldn't conflict with anything. If not, try it, maybe that will fix your issue.

 

And I know this sounds obvious, but make sure to have an animation on the 113th slot in your database.

The ABS demo got extra animations set up in the database, so if your project doesn't, you will need to change the animation ID in the note-tag or make new animations in your database.

Share this post


Link to post
Share on other sites

I tested out what Dymdez said and copied one of the weapons from the clean version and it worked so it definitely have something to do with notetags in the Weapons Tags. But I don't know which party is causing the issue. It's not Tool Invoke Skill because they're both set to 0.

 

Here is the Weapon tag from the clean version

 

 

User Graphic = $Axe
User Anime Speed = 18
Tool Cooldown = 20
Tool Graphic = nil
Tool Index = 0
Tool Size = 1
Tool Distance = 1
Tool Effect Delay = 10
Tool Destroy Delay = 20
Tool Speed = 5
Tool Cast Time = 0
Tool Cast Animation = 0
Tool Blow Power = 0
Tool Piercing = true
Tool Animation When = end
Tool Animation Repeat = false
Tool Special = nil
Tool Target = false
Tool Invoke Skill = 0
Tool Guard Rate = 0
Tool Knockdown Rate = 0
Tool Sound Se = nil
Tool Cooldown Display = false
Tool Item Cost = 0
Tool Short Jump = false
Tool Through = true
Tool Priority = 1
Tool Hit Shake = false
Tool Self Damage = false
Tool Combo Tool = nil

 

 

 

Here is the Weapon tag I have been using

 

 

User Graphic = $GoldSword
User Anime Speed = 10
Tool Cooldown = 11
Tool Graphic = nil
Tool Index = 0
Tool Size = 1
Tool Distance = 1
Tool Effect Delay = 0
Tool Destroy Delay = 10
Tool Speed = 5
Tool Cast Time = 0
Tool Cast Animation = 0
Tool Blow Power = 0
Tool Piercing = true
Tool Animation When = hit
Tool Animation Repeat = false
Tool Special = nil
Tool Target = false
Tool Invoke Skill = 0
Tool Guard Rate = 0
Tool Knockdown Rate = 0
Tool Sound Se = Wind7
Tool Cooldown Display = false
Tool Item Cost = 0
Tool Short Jump = false
Tool Through = true
Tool Priority = 3
Tool Hit Shake = false
Tool Self Damage = false
Tool Combo Tool = nil

 

 

 

Share this post


Link to post
Share on other sites

There is no such thing as "Tool Priority = 3" in the engine by default.

That thing sets up the priority of the tool, and those are:

0 = Below Characters, 1 = Same as Characters, 2 = Above Characters

 

No other options, unless you use a custom script which adds some new ones (no idea why would anyone need more than the default ones thou).

 

The other thing is the Effect Delay. It should be set to 1 at least. 0 might cause some errors, although I never tested it yet.

 

Can't see any other possible cause for errors. Change these, see if it will help or not.

Share this post


Link to post
Share on other sites

ayy any of you guys know how to make a skill where theres basically a animation that repeats on you and you can move around with it damaging things that touch it?

i've made around 40 skills for my game and none of them allow me to move while it is happening, im basically tryna create a shield-like skill.

Share this post


Link to post
Share on other sites

That should not affect the KO animation.

 

Still works for me in any project I tried, even with the animation set to "hit" type.

It's that it doesn't work for me. Can I see what notetags you used?

 

ayy any of you guys know how to make a skill where theres basically a animation that repeats on you and you can move around with it damaging things that touch it?

i've made around 40 skills for my game and none of them allow me to move while it is happening, im basically tryna create a shield-like skill.

I just thought of this so I haven't tested it, but try making invisible summon skills that follow you and use the skill(s) you made to make it look like it moves with you.

Share this post


Link to post
Share on other sites

 

ayy any of you guys know how to make a skill where theres basically a animation that repeats on you and you can move around with it damaging things that touch it?

i've made around 40 skills for my game and none of them allow me to move while it is happening, im basically tryna create a shield-like skill.

I just thought of this so I haven't tested it, but try making invisible summon skills that follow you and use the skill(s) you made to make it look like it moves with you.

 

i've tried that but it dosent work the way i want it to work xD the skill looks out of sync because when using the skill it dose not follow so the skill would be used like 3 steps behind or more.

Share this post


Link to post
Share on other sites

It's that it doesn't work for me. Can I see what notetags you used?

It really doesn't matter what note-tags I use, they all work for me.

The note-tags are regular tool note-tags, freshly made or copied from the demo, all of them work.

The enemy note-tags are the same, new or sample ones from the demo, everything works.

 

I tested them in 4 different projects, 1 of these was in the clean demo, 1 of it was in my own, abandoned project, and 2 of it was in other people's project.

The last 3 projects got tons of custom scripts added as well.

 

If you can upload a demo of your project for me, I will try to debug it for you when I get some free time.

I suspect some compatibility issues, because no matter how I try to trigger the issue you get, I simply can't.

 

Here is a weapon note-tag I tested:

 

<secondary: a4>

<charged tool: sword1>

<tool light: torch>

<anim set max wait: 45>

<new effect delay>

User Graphic = combo Sword1

User Anime Speed = 30

Tool Cooldown = 24

Tool Graphic = nil

Tool Index = 0

Tool Size = 1

Tool Distance = 1

Tool Effect Delay = 5

Tool Destroy Delay = 6

Tool Speed = 5

Tool Cast Time = 0

Tool Cast Animation = 0

Tool Blow Power = 0

Tool Piercing = false

Tool Animation When = hit

Tool Animation Repeat = false

Tool Special = nil

Tool Target = false

Tool Invoke Skill = 25

Tool Guard Rate = 0

Tool Knockdown Rate = 0

Tool Sound Se = Blow4p1

Tool Cooldown Display = true

Tool Item Cost = 0

Tool Short Jump = false

Tool Through = true

Tool Priority = 1

Tool Hit Shake = false

Tool Self Damage = false

Tool Combo Tool = nil

<persistent>

CD Bonus = <5 AGI, 15 ATK>

 

Ignore the irrelevant note-tags, those are for other scripts.

But it really doesn't matter which one I use, they work.

Share this post


Link to post
Share on other sites

 

It's that it doesn't work for me. Can I see what notetags you used?

It really doesn't matter what note-tags I use, they all work for me.

The note-tags are regular tool note-tags, freshly made or copied from the demo, all of them work.

The enemy note-tags are the same, new or sample ones from the demo, everything works.

 

I tested them in 4 different projects, 1 of these was in the clean demo, 1 of it was in my own, abandoned project, and 2 of it was in other people's project.

The last 3 projects got tons of custom scripts added as well.

 

If you can upload a demo of your project for me, I will try to debug it for you when I get some free time.

I suspect some compatibility issues, because no matter how I try to trigger the issue you get, I simply can't.

 

Here is a weapon note-tag I tested:

 

<secondary: a4>

<charged tool: sword1>

<tool light: torch>

<anim set max wait: 45>

<new effect delay>

User Graphic = combo Sword1

User Anime Speed = 30

Tool Cooldown = 24

Tool Graphic = nil

Tool Index = 0

Tool Size = 1

Tool Distance = 1

Tool Effect Delay = 5

Tool Destroy Delay = 6

Tool Speed = 5

Tool Cast Time = 0

Tool Cast Animation = 0

Tool Blow Power = 0

Tool Piercing = false

Tool Animation When = hit

Tool Animation Repeat = false

Tool Special = nil

Tool Target = false

Tool Invoke Skill = 25

Tool Guard Rate = 0

Tool Knockdown Rate = 0

Tool Sound Se = Blow4p1

Tool Cooldown Display = true

Tool Item Cost = 0

Tool Short Jump = false

Tool Through = true

Tool Priority = 1

Tool Hit Shake = false

Tool Self Damage = false

Tool Combo Tool = nil

<persistent>

CD Bonus = <5 AGI, 15 ATK>

 

Ignore the irrelevant note-tags, those are for other scripts.

But it really doesn't matter which one I use, they work.

 

I PM'd you the demo

 

 

 

ayy any of you guys know how to make a skill where theres basically a animation that repeats on you and you can move around with it damaging things that touch it?

i've made around 40 skills for my game and none of them allow me to move while it is happening, im basically tryna create a shield-like skill.

I just thought of this so I haven't tested it, but try making invisible summon skills that follow you and use the skill(s) you made to make it look like it moves with you.

 

i've tried that but it dosent work the way i want it to work xD the skill looks out of sync because when using the skill it dose not follow so the skill would be used like 3 steps behind or more.

 

Ok how about making it into a state?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×